ConwayLife.com - A community for Conway's Game of Life and related cellular automata
Home  •  LifeWiki  •  Forums  •  Download Golly

APGmera error.

Has something gone haywire? Let us know about it!

APGmera error.

Postby Moth-Wingthane » August 29th, 2016, 4:59 pm

One of my apgmera installations has broken. It has been working perfectly for months, but when I went to change the rule I got this:

apgmera v3.28: Rule b3s23 does not match desired rule b35s136.
Skipping updates; use --update to update apgmera automatically.
Configuring rule b35s136; symmetry C1
Valid rulestring: b35s136
Valid symmetry: C1
Rule integer:     37928
Rule circuit:     [-124-044-250-461-354-782]
Rule integer:     37928
Rule circuit:     [-124-044-250-461-354-782]
Rule integer:     37928
Rule circuit:     [-124-044-250-461-354-782]
Success!
g++ -c -Wall -O3 -march=native -fopenmp -DUSE_OPEN_MP main.cpp -o main.o
g++ -fopenmp main.o includes/sha256.o includes/md5.o includes/happyhttp.o gollybase/bigint.o gollybase/lifealgo.o gollyb
ase/qlifealgo.o gollybase/util.o gollybase/lifepoll.o gollybase/liferules.o gollybase/viewport.o gollybase/readpattern.o
gollybase/qlifedraw.o -o apgmera
main.o: In function `linearlyse[abi:cxx11](lifealgo*, int)':
main.cpp:(.text+0x36f1): undefined reference to `md5(std::__cxx11::basic_string<char, std::char_traits<char>, std::alloc
ator<char> >)'
main.o: In function `authenticate[abi:cxx11](char const*, char const*)':
main.cpp:(.text+0x3f92): undefined reference to `sha256(std::__cxx11::basic_string<char, std::char_traits<char>, std::al
locator<char> >)'
main.o: In function `SoupSearcher::submitResults(std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator
<char> >, std::__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >, long long, int)':
main.cpp:(.text._ZN12SoupSearcher13submitResultsENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES5_xi[_ZN12SoupSear
cher13submitResultsENSt7__cxx1112basic_stringIcSt11char_traitsIcESaIcEEES5_xi]+0x174): undefined reference to `md5(std::
__cxx11::basic_string<char, std::char_traits<char>, std::allocator<char> >)'
collect2: error: ld returned 1 exit status
makefile:45: recipe for target 'apgmera' failed
make: *** [apgmera] Error 1


I tried a recompile and got exactly the same. Do I need to scrub it and start over?
Moth-Wingthane
 
Posts: 12
Joined: October 11th, 2015, 8:54 pm

Re: APGmera error.

Postby Apple Bottom » August 29th, 2016, 6:32 pm

A similar issue was reported and solved here. In a nutshell: try running "make clean" before "make", especially if you recently updated/upgraded your system, and see if that helps.
If you speak, your speech must be better than your silence would have been. — Arabian proverb

Catagolue: Apple Bottom • Life Wiki: Apple Bottom • Twitter: @_AppleBottom_

Proud member of the Pattern Raiders!
User avatar
Apple Bottom
 
Posts: 989
Joined: July 27th, 2015, 2:06 pm

Re: APGmera error.

Postby Moth-Wingthane » August 29th, 2016, 6:36 pm

Update...

Thanks to some help from Apple Bottom, "make clean" allowed me to recompile and now we're up and running again. Much simpler and quicker solution than I had expected :)
Moth-Wingthane
 
Posts: 12
Joined: October 11th, 2015, 8:54 pm


Return to Bugs & Errors

Who is online

Users browsing this forum: No registered users and 1 guest