ConwayLife.com - A community for Conway's Game of Life and related cellular automata
Home  •  LifeWiki  •  Forums  •  Download Golly

Multiple Bugs, see post for details

Has something gone haywire? Let us know about it!

Multiple Bugs, see post for details

Postby Gamedziner » July 1st, 2019, 8:33 am

Moosey wrote:Also
x = 12, y = 5, rule = B2in3aeijn/S234e
9bo$3o5b3o$2bo4b2ob2o$3o5b3o$9bo!

Weird glitchiness: Delete every cell except the cells at locations (0,1), (1,1), (2,1), (2,2), and (1,3), and at generation 11 four cells will appear: (9,0), (8,1), (9,1), and (10,1). If you delete those cells, the history shows the cells at (0,2), (1,2), (2,2), and (1,3) as having just died, even after hundreds of generations. Deleting the cell at (9,1) (and not the other three) results in cells being born at (7,1) and (11,1). Issues with the history updating seem to be related to the pattern's bounding box at various points in time, but I'm not sure what causes the rest. Last thing: It now seems impossible to delete history cells, except by putting live cells over them and deleting those cells.
x = 81, y = 96, rule = LifeHistory
58.2A$58.2A3$59.2A17.2A$59.2A17.2A3$79.2A$79.2A2$57.A$56.A$56.3A4$27.
A$27.A.A$27.2A21$3.2A$3.2A2.2A$7.2A18$7.2A$7.2A2.2A$11.2A11$2A$2A2.2A
$4.2A18$4.2A$4.2A2.2A$8.2A!
Gamedziner
 
Posts: 784
Joined: May 30th, 2016, 8:47 pm
Location: Milky Way Galaxy: Planet Earth

Re: Multiple Bugs, see post for details

Postby rowett » July 1st, 2019, 10:15 am

Gamedziner wrote:Weird glitchiness: Delete every cell except the cells at locations (0,1), (1,1), (2,1), (2,2), and (1,3), and at generation 11 four cells will appear: (9,0), (8,1), (9,1), and (10,1).

Thanks for reporting! This should have been fixed in Build 357.

Gamedziner wrote:Last thing: It now seems impossible to delete history cells, except by putting live cells over them and deleting those cells.

Yes I haven't decided what to do with editing and history cells yet. As far as the editor and undo/redo system are concerned they don't exist (i.e. they're just dead cells).
User avatar
rowett
Moderator
 
Posts: 1628
Joined: January 31st, 2013, 2:34 am
Location: UK

Re: Multiple Bugs, see post for details

Postby AforAmpere » July 3rd, 2019, 12:05 pm

I'm not going to create another thread for this, but there's a weird thing going on (I don't know if it happens for non-LTL stuff)
If you run this pattern the first time, it randomly dies at gen 76:
x = 11, y = 10, rule = R4,C0,M1,S7..7,B8..8,NM
3bo2bo$2bo7bo$10bo$10bo$10bo$o9bo$10bo$bo8bo$10bo$4bobo!

If you run it again, it goes normally. I'm not sure what the reason is.
I and wildmyron manage the 5S project, which collects all known spaceship speeds in Isotropic Non-totalistic rules.

Things to work on:
- Find a (7,1)c/8 ship in a Non-totalistic rule
- Finish a rule with ships with period >= f_e_0(n) (in progress)
AforAmpere
 
Posts: 1045
Joined: July 1st, 2016, 3:58 pm

Re: Multiple Bugs, see post for details

Postby rowett » July 3rd, 2019, 2:17 pm

AforAmpere wrote:I'm not going to create another thread for this, but there's a weird thing going on (I don't know if it happens for non-LTL stuff)

This has been fixed and will be in the next release. Thanks for reporting!
User avatar
rowett
Moderator
 
Posts: 1628
Joined: January 31st, 2013, 2:34 am
Location: UK


Return to Bugs & Errors

Who is online

Users browsing this forum: No registered users and 3 guests