lifeviewer bug

Has something gone haywire? Let us know about it!
User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » August 8th, 2021, 10:36 am

wwei47 wrote:
August 8th, 2021, 9:34 am
I remember running a huge spacefiller pattern on my phone, when the page decided to refresh itself. I cannot remember what the spacefiller was.
Very large patterns on phones can cause the browser to run out of memory. At which point the browser will refresh/restart.

pcallahan
Posts: 710
Joined: April 26th, 2013, 1:04 pm

Re: lifeviewer bug

Post by pcallahan » October 8th, 2021, 2:00 am

I'm not sure if this thread is for any bug or a specific one, but LifeViewer just isn't working for me at all anymore. When I click on View, it flashes and does not show any pattern. Does this happen to anyone else? I'm using Chrome Version 94.0.4606.71 on MacOS 11.4.

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » October 8th, 2021, 6:47 am

pcallahan wrote:
October 8th, 2021, 2:00 am
I'm not sure if this thread is for any bug or a specific one, but LifeViewer just isn't working for me at all anymore. When I click on View, it flashes and does not show any pattern. Does this happen to anyone else? I'm using Chrome Version 94.0.4606.71 on MacOS 11.4.
Please post a link to the page that is not working. Also please open the Chrome developer console and let me know if there are any error messages when you click.

pcallahan
Posts: 710
Joined: April 26th, 2013, 1:04 pm

Re: lifeviewer bug

Post by pcallahan » October 8th, 2021, 11:24 am

rowett wrote:
October 8th, 2021, 6:47 am
Please post a link to the page that is not working. Also please open the Chrome developer console and let me know if there are any error messages when you click.
It's every page when I try to run LifeViewer (or it starts automatically). Chrome developer tools doesn't show any obvious problem. The API calls all return 200, and there is nothing on the console. It flashes when I move my mouse over it and otherwise leaves the cell area unrendered. Here's a screenshot:
Screen Shot 2021-10-08 at 8.12.17 AM.png
Screen Shot 2021-10-08 at 8.12.17 AM.png (429.97 KiB) Viewed 965 times
This is on my work computer and maybe that is configured in some way that interacts badly. I can try another computer at home.

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » October 8th, 2021, 11:53 am

Very strange indeed. Would be very interested in results from trying on your computer at home. Also do you know if it works in other browsers like Safari?

From the screenshot it looks like the image data buffer used to render the cells contains zeroes (which would make the pixels transparent with an alpha of zero). I can't imagine why that might be happening.

pcallahan
Posts: 710
Joined: April 26th, 2013, 1:04 pm

Re: lifeviewer bug

Post by pcallahan » October 8th, 2021, 12:12 pm

rowett wrote:
October 8th, 2021, 11:53 am
Very strange indeed. Would be very interested in results from trying on your computer at home. Also do you know if it works in other browsers like Safari?

From the screenshot it looks like the image data buffer used to render the cells contains zeroes (which would make the pixels transparent with an alpha of zero). I can't imagine why that might be happening.
It works fine in Safari. I just checked, but it's not my preferred browser. I also thought Chrome might have trouble with memory with too many tabs open, but I have closed a lot of them and restarted. That still could be the issue. I also cleared the cache. No luck there either. I guess I can use Safari as a stop-gap if this problem is limited to me.

User avatar
Andrew
Moderator
Posts: 845
Joined: June 2nd, 2009, 2:08 am
Location: Melbourne, Australia
Contact:

Re: lifeviewer bug

Post by Andrew » October 8th, 2021, 3:27 pm

pcallahan wrote:
October 8th, 2021, 2:00 am
... Does this happen to anyone else? I'm using Chrome Version 94.0.4606.71 on MacOS 11.4.
FWIW, I see exactly the same problem. Same version of Chrome, but on macOS 10.15.7.

bprentice
Posts: 828
Joined: September 10th, 2009, 6:20 pm
Location: Coos Bay, Oregon

Re: lifeviewer bug

Post by bprentice » October 9th, 2021, 2:47 am

I use two old iMacs.

The first runs OS X 10.10.5 and has Chrome 87.0.4280.141 installed.

The second runs OS X 10.11.8 and has Chrome 94.0.4606.81 installed.

I use the Firefox browser on both systems and have had no problems accessing www.conwaylife.com on either computer.

After reading the posts above I tried using Chrome and got the following error message on both computers.

Screen Shot 2021-10-08 at 11.12.21 PM.png
Screen Shot 2021-10-08 at 11.12.21 PM.png (1.23 MiB) Viewed 913 times

After clicking Advanced and then clicking Proceed ... everything seemed to work correctly on both computers. But why did this happen?

Brian Prentice
Last edited by bprentice on October 9th, 2021, 9:27 pm, edited 2 times in total.

adr
Posts: 4
Joined: June 26th, 2019, 11:15 pm

Re: lifeviewer bug

Post by adr » October 9th, 2021, 11:10 am

I also have the same problem. I'm on Mac OS 11.5.2, and it does the flashing on only google chrome. On safari, it works perfectly fine, but on chrome, it doesn't.

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » October 10th, 2021, 2:57 am

The fact that the issue is specific to Chrome on MacOS suggests a chrome bug on that platform.

From some googling it might be worth trying the following:

In Chrome settings go to Advanced->System and toggle the "Use hardware acceleration when available" and then restart Chrome.

pcallahan
Posts: 710
Joined: April 26th, 2013, 1:04 pm

Re: lifeviewer bug

Post by pcallahan » October 10th, 2021, 10:53 am

rowett wrote:
October 10th, 2021, 2:57 am
In Chrome settings go to Advanced->System and toggle the "Use hardware acceleration when available" and then restart Chrome.
Turning off hardware acceleration does seem to have fixed it. I'll see if this affects performance for other things (I'd prefer hardware acceleration if possible.)

adr
Posts: 4
Joined: June 26th, 2019, 11:15 pm

Re: lifeviewer bug

Post by adr » October 11th, 2021, 6:58 am

It seems to be fixed, although i haven't done anything with chrome since the last time i posted in this thread.

User avatar
LaundryPizza03
Posts: 1441
Joined: December 15th, 2017, 12:05 am
Location: Unidentified location "https://en.wikipedia.org/wiki/Texas"

Re: lifeviewer bug

Post by LaundryPizza03 » November 10th, 2021, 11:14 am

In macOS Big Sur 11.6, forum pages sometimes crash and reload when closing LifeViewer; the main page also tends to crash repeatedly. I'm not aware of this problem happening anywhere else.

Code: Select all

#C Sample pattern; click the big red X after opening the viewer.
x = 157, y = 38, rule = B3/S2-a3
2b3o5b3o5b3o9bo9bo7bo8bo5b3o11bo12bo7bo11bo34bo$bo3bo4bo2bo4bo2bo7b3o
7bobo5bobo6bobo3bobob2o8bobo11b2o5b2o12b2o32b2o$o5bo3bo7bo8b2ob3o5b2ob
2o3b2ob2o4b2ob2o3bo4bo7bobo9bobob2ob2obobo8bo2bo3b3o24bo3b2o$bobobo4bo
7bo3bo3bo2bo2b2o4b2o2bo3bo2b2o17bo4bo2bobo2bo4b2o4bo3bo4b2o7bo3bo4bo
23bo3b2o$2o3b2o4bobo4bo6bo3bo9bob2o3b2obo17bo5b2obobob2o4b2o3bobobobo
3b2o7bo3bobo2b2o20bo3bo$19bobo4bo2b2o9b3o3b3o24bobo3bobo10bo3bo12b2obo
6bo22b2ob3o$42bo3bo43b2o5b2o7b4o8b2o20bo$29bo10b3o3b3o25bo5bo12bobo14b
o31b2o$39bo2bo3bo2bo23bob2ob2obo8b2o2bo2b2o9bo8bo20b2ob4o8b2o$72b2o7b
2o25bo2b3o4b2o18b2o11bob2o$40bob2ob2obo22b2obobobobob2o6b3obob3o9bo2bo
b2obo3b2o14bo14bo3bo$38bobob2ob2obobo22bo2bobo2bo8b3obob3o6b2o6b2obobo
2bo14bo4bo9b2o2b2o$39b2obo3bob2o22bobobobobobo5b2o9b2o4bobo6b3o3b2o12b
2obob2o7bo$39b2obo3bob2o22bo9bo4bobo9bobo10bo3bobo29b2obob2o$41bo5bo
25bo7bo5bob2o7b2obo12bobo17bob2o10b2obo$41b3ob3o40bo11bo9bobo2bo17b3o
9bo2bo3bo$42b2ob2o62b2o24bo8bo5bo$42bo3bo40bobo9bobo29bobo10bo2b2o$88b
o11bo28b2o16b2o$40b3o3b3o38b2o5bo5b2o27bobo10bobo$40bo7bo39bo4bobo4bo
41bo2b2o$39b2o7b2o37bo5bobo5bo28bobo7b2o2bo$39bo2b2ob2o2bo37b2o4b3o4b
2o28bobo8b2obo$38b4o5b4o37b2o3bobo3b2o31bo6bobo$38bobo7bobo38bo2b2ob2o
2bo27bo3bob3o$37b2o11b2o37bobo5bobo28bobobo4bobo$37bo4bo3bo4bo37bobo5b
obo26bo2bobo2b2o2bo$36b3o11b3o40b3o30bo3bo6b2o$92bobobo29b2o3bo$91b2ob
ob2o30bo3bo$89b2o7b2o24b3ob3o$88b3o7b3o24b2o$126bo$86b2ob2o7b2ob2o$87b
ob2o7b2obo2$90bo7bo$90b2ob3ob2o!

Code: Select all

x = 4, y = 3, rule = B3-q4z5y/S234k5j
2b2o$b2o$2o!
LaundryPizza03 at Wikipedia

The latest edition of new-gliders.db.txt and oscillators.db.txt have 34415 spaceships and 1412 oscillators from outer-totalistic rules. You are invited to help!

hotdogPi
Posts: 573
Joined: August 12th, 2020, 8:22 pm

Re: lifeviewer bug

Post by hotdogPi » November 10th, 2021, 5:24 pm

LaundryPizza03 wrote:
November 10th, 2021, 11:14 am
In macOS Big Sur 11.6, forum pages sometimes crash and reload when closing LifeViewer; the main page also tends to crash repeatedly. I'm not aware of this problem happening anywhere else.
Same here, but it was an update to Safari 15 that caused it, not an update to the OS version. Having the LifeViewer window open is enough to trigger it (although it's random); no closing required.

It applies to LifeViewer anywhere, including on the wiki.
User:HotdogPi/My discoveries

Periods discovered: 6,8,10-16,18,20,21G,22,24,25,27-31,32SG,35,36,40,42,44,45,48,50,54G,55G,57G,60,63-66,70,74S,75,76S,84,96S,100,117G,120,126,128S,138,147,156,196S,217,486,576

S: SKOP
G: gun

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » November 11th, 2021, 1:21 am

hotdogPi wrote:
November 10th, 2021, 5:24 pm
Same here, but it was an update to Safari 15 that caused it, not an update to the OS version. Having the LifeViewer window open is enough to trigger it (although it's random); no closing required.

It applies to LifeViewer anywhere, including on the wiki.
In which case it's almost certainly an issue with Safari 15. Google shows there are a number of issues with Safari 15 so hopefully it'll improve as Apple fix it: https://www.macworld.co.uk/news/issues- ... 5-3808936/

User avatar
yujh
Posts: 2507
Joined: February 27th, 2020, 11:23 pm
Location: Toronto, On, Canada (加拿大,安大略省,多伦多)
Contact:

Re: lifeviewer bug

Post by yujh » November 22nd, 2021, 9:31 pm

Firefox. Draw a beehive in this pattern here: https://www.conwaylife.com/forums/viewt ... 89#p137989
Press space for some time, and draw a dot on top of that like

Code: Select all

bo$bo$obo$obo$bo!
press space continously. I goes into tow blocks instead of a hf. Sorta weird

(requires to press space bars without leaving it and probably need 100%cpu?)
Nothing to apgsearch? Try b38s23/C1!

B34kz5e7c8/S23-a4ityz5k!!!

b2n3-q5y6cn7s23-k4c8

B3-kq6cn8/S2-i3-a4ciyz8

B3-kq4z5e7c8/S2-ci3-a4ciq5ek6eik7

Rule modifier

Bored of Conway's Game of Life? Try Pedestrian Life -- not pedestrian at all!

hotdogPi
Posts: 573
Joined: August 12th, 2020, 8:22 pm

Re: lifeviewer bug

Post by hotdogPi » November 22nd, 2021, 9:34 pm

yujh wrote:
November 22nd, 2021, 9:31 pm
Firefox. Draw a beehive in this pattern here: https://www.conwaylife.com/forums/viewt ... 89#p137989
Press space for some time, and draw a dot on top of that like

Code: Select all

bo$bo$obo$obo$bo!
press space continously. I goes into tow blocks instead of a hf. Sorta weird

(requires to press space bars without leaving it and probably need 100%cpu?)
You're just holding the mouse button for two generations instead of one.
User:HotdogPi/My discoveries

Periods discovered: 6,8,10-16,18,20,21G,22,24,25,27-31,32SG,35,36,40,42,44,45,48,50,54G,55G,57G,60,63-66,70,74S,75,76S,84,96S,100,117G,120,126,128S,138,147,156,196S,217,486,576

S: SKOP
G: gun

User avatar
yujh
Posts: 2507
Joined: February 27th, 2020, 11:23 pm
Location: Toronto, On, Canada (加拿大,安大略省,多伦多)
Contact:

Re: lifeviewer bug

Post by yujh » November 22nd, 2021, 9:36 pm

hotdogPi wrote:
November 22nd, 2021, 9:34 pm
yujh wrote:
November 22nd, 2021, 9:31 pm
Firefox. Draw a beehive in this pattern here: https://www.conwaylife.com/forums/viewt ... 89#p137989
Press space for some time, and draw a dot on top of that like

Code: Select all

bo$bo$obo$obo$bo!
press space continously. I goes into tow blocks instead of a hf. Sorta weird

(requires to press space bars without leaving it and probably need 100%cpu?)
You're just holding the mouse button for two generations instead of one.
Oh Okay cool I guess :)
Nothing to apgsearch? Try b38s23/C1!

B34kz5e7c8/S23-a4ityz5k!!!

b2n3-q5y6cn7s23-k4c8

B3-kq6cn8/S2-i3-a4ciyz8

B3-kq4z5e7c8/S2-ci3-a4ciq5ek6eik7

Rule modifier

Bored of Conway's Game of Life? Try Pedestrian Life -- not pedestrian at all!

User avatar
wwei47
Posts: 1117
Joined: February 18th, 2021, 11:18 am

Re: lifeviewer bug

Post by wwei47 » November 23rd, 2021, 2:54 pm

Here's a few more that only appear on a Chromebook:
I have to press down Ctrl-Space for a long time before it starts stepping the selection forwards, after which it just steps it way too fast to "aim" for a specific generation.
LifeViewer completely ignores Alt-Up and Alt-Down.
Self-proclaimed synthesis "expert"
I collect statorless oscillators.

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » November 25th, 2021, 5:06 am

wwei47 wrote:
November 23rd, 2021, 2:54 pm
I have to press down Ctrl-Space for a long time before it starts stepping the selection forwards, after which it just steps it way too fast to "aim" for a specific generation.
I guess you just need to wait longer for the initial step. If you're holding down Ctrl-Space while waiting the keyboard repeat will create a backlog of keypresses that will get serviced once the initial step is finished.
wwei47 wrote:
November 23rd, 2021, 2:54 pm
LifeViewer completely ignores Alt-Up and Alt-Down.
When nudging a selection? Do Alt-Left and Alt-Right work? Do the UI buttons for nudge up and down work?
Which version of Chrome is running?

User avatar
wwei47
Posts: 1117
Joined: February 18th, 2021, 11:18 am

Re: lifeviewer bug

Post by wwei47 » November 25th, 2021, 10:35 am

rowett wrote:
November 25th, 2021, 5:06 am
I guess you just need to wait longer for the initial step. If you're holding down Ctrl-Space while waiting the keyboard repeat will create a backlog of keypresses that will get serviced once the initial step is finished.
<snip>
When nudging a selection? Do Alt-Left and Alt-Right work? Do the UI buttons for nudge up and down work?
Which version of Chrome is running?
1. On e it starts stepping, it steps once per frame, and I can't easily step one generation.
2. Yes, yes, yes, and the most recent version.
Self-proclaimed synthesis "expert"
I collect statorless oscillators.

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » November 25th, 2021, 10:43 am

wwei47 wrote:
November 25th, 2021, 10:35 am
1. On e it starts stepping, it steps once per frame, and I can't easily step one generation.
Is this because when you press Space it's stepping multiple times?

User avatar
wwei47
Posts: 1117
Joined: February 18th, 2021, 11:18 am

Re: lifeviewer bug

Post by wwei47 » November 25th, 2021, 10:52 am

rowett wrote:
November 25th, 2021, 10:43 am
Is this because when you press Space it's stepping multiple times?
It does nothing for a few seconds, then it starts stepping rapidly.
Self-proclaimed synthesis "expert"
I collect statorless oscillators.

User avatar
rowett
Moderator
Posts: 2481
Joined: January 31st, 2013, 2:34 am
Location: UK
Contact:

Re: lifeviewer bug

Post by rowett » November 25th, 2021, 11:20 am

wwei47 wrote:
November 25th, 2021, 10:52 am
rowett wrote:
November 25th, 2021, 10:43 am
Is this because when you press Space it's stepping multiple times?
It does nothing for a few seconds, then it starts stepping rapidly.
OK so I need to understand the timing. For example:
  1. Stop any playback
  2. Make a selection
  3. Press and release Ctrl-Space
  4. Pattern in selection should evolve 1 generation (how long does this take?)
  5. Press and release Ctrl-Space
  6. Pattern in selection should evolve 1 generation (how long does this take?)
  7. Press and hold down Ctrl-Space
  8. Pattern in selection should continue evolving (how fast is it evolving?)
  9. Release Ctrl-Space
  10. Evolution should stop (how quickly does it stop?)

User avatar
wwei47
Posts: 1117
Joined: February 18th, 2021, 11:18 am

Re: lifeviewer bug

Post by wwei47 » November 25th, 2021, 6:01 pm

rowett wrote:
November 25th, 2021, 11:20 am
OK so I need to understand the timing.
Sure.
1. Stop any playback
2. Make a selection
3. Press and release Ctrl-Space
4. Nothing happens
5. Press and release Ctrl-Space
6. Nothing happens
7. Press and hold down Ctrl-Space
8. Around half a second later, the pattern in selection starts evolving, and does so at a rate too fast for me to aim for any specific generation
9. Release Ctrl-Space
10. Evolution stops immediately
Self-proclaimed synthesis "expert"
I collect statorless oscillators.

Post Reply