Broken layout on LifeWiki

Has something gone haywire? Let us know about it!
Post Reply
User avatar
codeholic
Moderator
Posts: 1142
Joined: September 13th, 2011, 8:23 am
Location: Hamburg, Germany

Broken layout on LifeWiki

Post by codeholic » August 21st, 2015, 3:04 pm

The layout on Achim's p8 seems broken to me.
Ivan Fomichev

flipper77
Posts: 197
Joined: October 24th, 2010, 3:25 am
Location: Spokane, WA

Re: Broken layout on LifeWiki

Post by flipper77 » August 21st, 2015, 9:42 pm

codeholic wrote:The layout on Achim's p8 seems broken to me.
From what I've seen, it's way more than that one page: many pages exhibit the same behavior, although it appears to me that the affected pages are random, so I wouldn't know what's causing it. I'm going to take a wild, potentially inaccurate guess that it has to do with MediaWiki because Nathaniel mentioned it when I was asking about the broken navigation box that I used to find patterns with missing parameters, but it could very well be something else I'm not considering.

User avatar
Freywa
Posts: 589
Joined: June 23rd, 2011, 3:20 am
Location: Singapore
Contact:

Re: Broken layout on LifeWiki

Post by Freywa » August 22nd, 2015, 12:51 am

The folks at Wikipedia are changing the software frenetically. The styles and scripts are now loaded after the actual page content as per the HTML/CSS separation principle. You need to write a stylesheet.
Princess of Science, Parcly Taxel

User avatar
Nathaniel
Site Admin
Posts: 496
Joined: December 10th, 2008, 3:48 pm
Location: New Brunswick, Canada
Contact:

Re: Broken layout on LifeWiki

Post by Nathaniel » August 25th, 2015, 8:36 am

Whoa, sorry about this guys -- I have no idea what happened yet. I didn't change any of the LifeWiki software, so I'm not sure what suddenly changed to cause this.

Edit: I'll do another MediaWiki upgrade soon, which should resolve this issue.

Post Reply