Golly Module

Has something gone haywire? Let us know about it!
Post Reply
chiefjazzdiewltr
Posts: 1
Joined: March 29th, 2016, 9:05 pm

Golly Module

Post by chiefjazzdiewltr » March 29th, 2016, 9:11 pm

when running the python scripts in golly they errored so I dug a little and found that they weren't built for python 3.7 so I fixed that then the __init__.py script gave a new error which said that there was no module named "golly". So whats the new module name?

User avatar
dvgrn
Moderator
Posts: 5888
Joined: May 17th, 2009, 11:00 pm
Location: Madison, WI
Contact:

Re: Golly Module

Post by dvgrn » March 29th, 2016, 10:16 pm

chiefjazzdiewltr wrote:when running the python scripts in golly they errored so I dug a little and found that they weren't built for python 3.7 so I fixed that then the __init__.py script gave a new error which said that there was no module named "golly". So whats the new module name?
"golly" is the correct module name. Golly works with Python 2.x -- the leap to Python 3.x still hasn't been made yet. Also there seems to be a problem with the 2.7.11 64-bit Windows installer, so it's best to install 2.7.10 or earlier.

If you have a workable Python version installed -- 2.7.10 or earlier, 32-bit or 64-bit, depending on which version of Golly you downloaded -- then the scripts should run with no trouble.

If they don't, please be more specific about your OS, Golly, and Python versions, and what script you're trying to run, and I'll see what else I can think of.

Post Reply