solved: Golly build problems on Linux

Has something gone haywire? Let us know about it!
Post Reply
User avatar
martin.novy
Posts: 142
Joined: October 22nd, 2014, 6:22 am
Location: Czechia, EU
Contact:

solved: Golly build problems on Linux

Post by martin.novy » July 7th, 2020, 11:47 am

my shell commands and their results :

##I have downloaded from https://sourceforge.net/projects/golly/ ... golly-3.3/
tar xvf golly-3.3-src.tar.gz
##I have made a snapshot of the virtual machine where I build Golly
##uname -a
##Linux martin-VirtualBox 4.18.0-15-generic #16~18.04.1-Ubuntu SMP Thu Feb 7 14:06:04 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

EDIT: I should have read ~/Downloads/golly-3.3-src/docs/Build.html

:?: Question1: this Build.html is the best available document how to build Golly on Linux ... ?
(BTW, I have found an unofficial copy https://github.com/AlephAlpha/golly/blo ... Build.html )
(EDIT: https://sourceforge.net/p/golly/code/ci ... Build.html )

----

wget https://github.com/wxWidgets/wxWidgets/ ... .5.tar.bz2
sudo apt-get install mesa-common-dev
sudo apt-get install freeglut3-dev
tar xvf wxWidgets-3.0.5.tar.bz2
cd wxWidgets-3.0.5/
mkdir build-gtk
cd build-gtk
../configure --with-gtk --disable-shared --enable-unicode --with-opengl
this failed:
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.
googing this message was not easy

at this point I panicked, and

sudo apt-get install wx3.0-headers #3.0.4
sudo apt-get install wx-common
sudo apt-get install wxglade

maybe I will have to revert to the snapshot of the virtual machine that I have made in the beginning

----

EDIT 2: my mistake, I apologize
Question2: I could not find
local-gtk-template.mk
... actually any *.mk except
local-win-template.mk
((EDIT: I have found it now
https://sourceforge.net/p/golly/code/ci ... emplate.mk))
-----

sudo apt-get install python2.7-dev
sudo apt-get install libgtk2.0-dev

:!: interestingly, after this , the
../configure --with-gtk --disable-shared --enable-unicode --with-opengl
succeeds

----

I am going to revert to the snapshot of the virtual machine that I have made in the beginning

(EDIT there is also an AppImage viewtopic.php?f=4&t=3627&p=86021#p86042 )
Last edited by martin.novy on July 10th, 2020, 9:58 am, edited 3 times in total.

User avatar
Andrew
Moderator
Posts: 849
Joined: June 2nd, 2009, 2:08 am
Location: Melbourne, Australia
Contact:

Re: Golly build problems on Linux

Post by Andrew » July 7th, 2020, 8:40 pm

martin.novy wrote:
July 7th, 2020, 11:47 am
:?: Question1: this Build.html is the best available document how to build Golly on Linux ... ?
Yep -- if there was something better I'm pretty sure we would have included it!

Looking at your results, the only problem I can see in Build.html is that the command for installing libgtk2.0-dev should be in the section on how to build wxWidgets (instead of in the later section on how to build Golly). I've committed that fix.
:?: Question2: could not find local-gtk-template.mk
That's not in the 3.3 src distribution so you must have been looking in a newer Build.html. That file will be part of the 3.4 release.
I am going to revert to the snapshot of the virtual machine that I have made in the beginning
Not sure why you gave up at that point -- you were nearly done! If the configure step succeeds then you do:

Code: Select all

make
sudo make install
sudo ldconfig
And assuming that succeeds you can build and run golly:

Code: Select all

cd /path/to/golly/gui-wx
make -f makefile-gtk
../golly

User avatar
martin.novy
Posts: 142
Joined: October 22nd, 2014, 6:22 am
Location: Czechia, EU
Contact:

solved: Golly build problems on Linux

Post by martin.novy » July 9th, 2020, 8:12 am

Andrew wrote:
July 7th, 2020, 8:40 pm

Looking at your results, the only problem I can see in Build.html is that the command for installing libgtk2.0-dev should be in the section on how to build wxWidgets (instead of in the later section on how to build Golly). I've committed that fix.
Thank you for the fix.

I have reverted my virtual machine, and then I have compiled everything successfully, and Golly works.

User avatar
martin.novy
Posts: 142
Joined: October 22nd, 2014, 6:22 am
Location: Czechia, EU
Contact:

Re: solved: Golly build problems on Linux

Post by martin.novy » July 10th, 2020, 10:06 am

I have also done now 1 more thing , maybe not important ...

months ago, I did
sudo apt install golly #2.8

now I have done
sudo apt remove --purge golly #2.8
sudo apt autoremove # 2 apt libwx*

----

(now Golly 3.3 works OK)

----
BTW, distantly related is:

Post Reply