Some posts have gone missing

Has something gone haywire? Let us know about it!
Post Reply
User avatar
Andrew
Moderator
Posts: 769
Joined: June 2nd, 2009, 2:08 am
Location: Melbourne, Australia
Contact:

Some posts have gone missing

Post by Andrew » March 20th, 2011, 6:55 pm

Some time in the last few days I noticed that a few posts in the "Golly Scripts" thread (in the Scripts section) seem to have disappeared! There was a post by flipper77 (who has since added a new one), one by 137ben and one by me about adding random-fill.py to the Golly Scripts Database. Have they disappeared in the move to a new server? Any chance of getting them back?

User avatar
Nathaniel
Site Admin
Posts: 575
Joined: December 10th, 2008, 3:48 pm
Location: New Brunswick, Canada
Contact:

Re: Some posts have gone missing

Post by Nathaniel » March 20th, 2011, 11:37 pm

Oh dear... any idea what the (approximate) dates on the posts were? They weren't lost as a result of a move to the new server (that still hasn't happened -- I'm still tinkering with the applet), so I'm not sure what could possibly have happened to them. I'll dig around for them but I'm not sure how I would get them back other than a full database restore, which would lose anything that has been added to the forum since they disappeared.

User avatar
Andrew
Moderator
Posts: 769
Joined: June 2nd, 2009, 2:08 am
Location: Melbourne, Australia
Contact:

Re: Some posts have gone missing

Post by Andrew » March 21st, 2011, 2:02 am

Nathaniel wrote:Oh dear... any idea what the (approximate) dates on the posts were?
Can't be exact I'm afraid. Mine was the latest of the 3 and was posted late last week, maybe around March 17th. All 3 were quite short.

User avatar
Nathaniel
Site Admin
Posts: 575
Joined: December 10th, 2008, 3:48 pm
Location: New Brunswick, Canada
Contact:

Re: Some posts have gone missing

Post by Nathaniel » March 21st, 2011, 10:57 am

According to the forum logs, flipper77 deleted his own post in the Golly Scripts thread yesterday (March 20) in the morning. It seems to have absolutely no record of the other two posts though, so I'm not sure what could be going on.

User avatar
Andrew
Moderator
Posts: 769
Joined: June 2nd, 2009, 2:08 am
Location: Melbourne, Australia
Contact:

Re: Some posts have gone missing

Post by Andrew » March 21st, 2011, 5:59 pm

Sounds like there's a bug somewhere, because I definitely didn't delete my post. I'll try to reproduce the bug with a few test messages...

EDIT: Couldn't reproduce bug so I'll delete all my test messages.

137ben
Posts: 343
Joined: June 18th, 2010, 8:18 pm

Re: Some posts have gone missing

Post by 137ben » March 21st, 2011, 6:02 pm

Test message 4

137ben
Posts: 343
Joined: June 18th, 2010, 8:18 pm

Re: Some posts have gone missing

Post by 137ben » March 21st, 2011, 6:03 pm

Didn't seem to mess anything up...

flipper77
Posts: 197
Joined: October 24th, 2010, 3:25 am
Location: Spokane, WA

Re: Some posts have gone missing

Post by flipper77 » March 21st, 2011, 7:07 pm

The reason I had my post deleted was that I thought those 2 posts were deleted for some particular reason I may have not known about, but now I see that some bug has caused the posts to go missing, I found that to be weird myself.

Post Reply