Unable to post posts containing emojis

Has something gone haywire? Let us know about it!
Post Reply
User avatar
toroidalet
Posts: 1016
Joined: August 7th, 2016, 1:48 pm
Location: my computer
Contact:

Unable to post posts containing emojis

Post by toroidalet » August 22nd, 2017, 10:33 pm

While trying to make a post to the random posts containing a poop emoji I got the following error:
Screen Shot 2017-08-22 at 7.37.32 PM.png
Screen Shot 2017-08-22 at 7.37.32 PM.png (74.86 KiB) Viewed 3143 times
What's really weird is that they render fine in the preview menu but give this error when sending the post.
"Build a man a fire and he'll be warm for a day. Set a man on fire and he'll be warm for the rest of his life."

-Terry Pratchett

User avatar
drc
Posts: 1664
Joined: December 3rd, 2015, 4:11 pm
Location: creating useless things in OCA

Re: Unable to post posts containing emojis

Post by drc » August 22nd, 2017, 10:38 pm

I can confirm this bug. I don't get why this would happen??

typing \xF0\x9F\x92\xA9 doesn't do anything
This post was brought to you by the letter D, for dishes that Andrew J. Wade won't do. (Also Daniel, which happens to be me.)
Current rule interest: B2ce3-ir4a5y/S2-c3-y

User avatar
toroidalet
Posts: 1016
Joined: August 7th, 2016, 1:48 pm
Location: my computer
Contact:

Re: Unable to post posts containing emojis

Post by toroidalet » August 22nd, 2017, 10:40 pm

drc wrote:\xF0\x9F\x92\xA9 doesn't do anything
It represents a poop emoji (or potentially anything unicode that isn't supported). Changing the symbol will probably give a different code. I would presume the bug would be because the forums don't have support for emojis, but it renders fine in the preview, which is confusing.
"Build a man a fire and he'll be warm for a day. Set a man on fire and he'll be warm for the rest of his life."

-Terry Pratchett

Post Reply